Задание №6094. Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один или четыре камня либо увеличить количество камней в куче в три раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней. Игра завершается в тот момент, когда количество камней в куче становится не менее 67. Победителем считается игрок, сделавший последний ход, т.е. первым получивший кучу, состоящую из 67 или более камней. В начальный момент в куче было S камней; 1 ≤ S ≤ 66. Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Задание №6094.
Анализ алгоритма логической игры. ЕГЭ по информатике

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один или четыре камня либо увеличить количество камней в куче в три раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

Игра завершается в тот момент, когда количество камней в куче становится не менее 67.

Победителем считается игрок, сделавший последний ход, т.е. первым получивший кучу, состоящую из 67 или более камней.

В начальный момент в куче было S камней; 1 ≤ S ≤ 66.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Пояснение:
Решим задание, написав программу на языке программирования Python. В коде перебираются все значения S от 1 до 66. Условие: Петя не может выиграть сразу (not can_win_immediately(S)), но для любого его хода существует ход Вани, который сразу делает ≥67. Таким образом, находится такое начальное число камней, при котором Ваня всегда выигрывает первым своим ходом.

TARGET = 67
moves = lambda s: (s+1, s+4, s*3)

def can_win_immediately(s):
    return any(m>=TARGET for m in moves(s))

ans = [S for S in range(1, TARGET)
         if (not can_win_immediately(S))
         and all(any(m>=TARGET for m in moves(S1)) for S1 in moves(S))]

print(ans)

Таким образом, 22 — минимальное значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Показать ответ

Источник: Открытый вариант — 2025
Сообщить об ошибке


Тест с похожими заданиями