Задание №6099. Файл, необходимый для выполнения задания: ссылка для скачивания. Текстовый файл состоит из десятичных цифр и заглавных букв латинского алфавита. Определите в этом файле последовательность идущих подряд символов, представляющих собой запись максимального чётного 14-ричного числа. В ответе запишите количество символов (значащих цифр в записи числа) в этой последовательности. Примечание. Латинские буквы A, B, C и D означают цифры из алфавита 14-ричной системы счисления.


Задание №6099.
Создание собственной программы. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Текстовый файл состоит из десятичных цифр и заглавных букв латинского алфавита. Определите в этом файле последовательность идущих подряд символов, представляющих собой запись максимального чётного 14-ричного числа. В ответе запишите количество символов (значащих цифр в записи числа) в этой последовательности.

Примечание. Латинские буквы A, B, C и D означают цифры из алфавита 14-ричной системы счисления.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def is_even_14(number_string):
    """Проверяет, является ли 14-ричное число четным."""
    return number_string[-1] in '02468AC'

def is_14_digit_character(character_string):
    """Проверяет, относится ли символ к 14-ричному алфавиту"""
    return character_string in '0123456789ABCD'

# Чтение файла
with open('input.txt', 'r') as file:
    content = file.read()

max_even_number = ''
    
# Ищем все последовательности символов
current_number = ''
for char in content:
    if is_14_digit_character(char):
        current_number += char
    else:
        if current_number and is_even_14(current_number):
            if len(current_number.lstrip('0')) > len(max_even_number):
                max_even_number = current_number
        current_number = ''

# Проверяем последнюю последовательность
if current_number and is_even_14(current_number):
    if len(current_number.lstrip('0')) > len(max_even_number):
        max_even_number = current_number

# Выводим длину максимального четного 14-ричного числа
print(len(max_even_number))

Таким образом, 865 — количество идущих подряд символов максимального чётного 14-ричного числа.

Показать ответ

Источник: Открытый вариант — 2025
Сообщить об ошибке


Тест с похожими заданиями