Задание №6102. Архив, необходимый для выполнения задания: ссылка для скачивания. Фрагмент звёздного неба спроецирован на плоскость с декартовой системой координат. Учёный решил провести кластеризацию полученных точек, являющихся изображениями звёзд, то есть разбить их множество на N непересекающихся непустых подмножеств (кластеров), таких, что точки каждого подмножества лежат внутри прямоугольника со сторонами длиной H и W, причём эти прямоугольники между собой не пересекаются. Стороны прямоугольников не обязательно параллельны координатным осям. Гарантируется, что такое разбиение существует и единственно для заданных размеров прямоугольников. Будем называть центром кластера точку этого кластера, сумма расстояний от которой до всех остальных точек кластера минимальна. Для каждого кластера гарантируется единственность его центра. Расстояние между двумя точками на плоскости A(x1, y1) и B(x2, y2) вычисляется по формуле: $$ d(A, B) = \sqrt{(x_2 - x_1)^2+(y_2 - y_1)^2}. $$ В файле A хранятся координаты точек двух кластеров, где H = 6, W = 6 для каждого кластера. В каждой строке записана информация о расположении на карте одной точки: сначала координата x, затем координата y. Известно, что количество точек не превышает 1000. В файле Б хранятся координаты точек трёх кластеров, где H = 8, W = 8 для каждого кластера. Известно, что количество точек не превышает 10 000. Структура хранения информации в файле Б аналогична структуре в файле А. Для каждого файла определите координаты центра каждого кластера, затем вычислите два числа: Px – среднее арифметическое абсцисс центров кластеров, и Py – среднее арифметическое ординат центров кластеров. В ответе запишите четыре числа: в первой строке – сначала абсолютное значение целой части произведения Px × 10 000, затем абсолютное значение целой части произведения Py × 10 000 для файла А; во второй строке – аналогичные данные для файла Б. Возможные данные одного из файлов проиллюстрированы графиком. Внимание! График приведён в иллюстративных целях для произвольных значений, не имеющих отношения к заданию. Для выполнения задания используйте данные из прилагаемого файла.


Задание №6102.
Создание собственной программы. ЕГЭ по информатике

Архив, необходимый для выполнения задания: ссылка для скачивания.

Фрагмент звёздного неба спроецирован на плоскость с декартовой системой координат. Учёный решил провести кластеризацию полученных точек, являющихся изображениями звёзд, то есть разбить их множество на N непересекающихся непустых подмножеств (кластеров), таких, что точки каждого подмножества лежат внутри прямоугольника со сторонами длиной H и W, причём эти прямоугольники между собой не пересекаются. Стороны прямоугольников не обязательно параллельны координатным осям. Гарантируется, что такое разбиение существует и единственно для заданных размеров прямоугольников.

Будем называть центром кластера точку этого кластера, сумма расстояний от которой до всех остальных точек кластера минимальна. Для каждого кластера гарантируется единственность его центра. Расстояние между двумя точками на плоскости A(x1, y1) и B(x2, y2) вычисляется по формуле: $$ d(A, B) = \sqrt{(x_2 - x_1)^2+(y_2 - y_1)^2}. $$ В файле A хранятся координаты точек двух кластеров, где H = 6, W = 6 для каждого кластера. В каждой строке записана информация о расположении на карте одной точки: сначала координата x, затем координата y. Известно, что количество точек не превышает 1000.

В файле Б хранятся координаты точек трёх кластеров, где H = 8, W = 8 для каждого кластера. Известно, что количество точек не превышает 10 000. Структура хранения информации в файле Б аналогична структуре в файле А.

Для каждого файла определите координаты центра каждого кластера, затем вычислите два числа: Px – среднее арифметическое абсцисс центров кластеров, и Py – среднее арифметическое ординат центров кластеров.

В ответе запишите четыре числа: в первой строке – сначала абсолютное значение целой части произведения Px × 10 000, затем абсолютное значение целой части произведения Py × 10 000 для файла А; во второй строке – аналогичные данные для файла Б.

Возможные данные одного из файлов проиллюстрированы графиком.

Внимание! График приведён в иллюстративных целях для произвольных значений, не имеющих отношения к заданию. Для выполнения задания используйте данные из прилагаемого файла.



Пояснение:
Вначале на основе имеющихся данных построим в Excel для каждого из файлов точечную диаграмму. Для этого необходимо выделить столбцы с данными, перейти во вкладку «Вставка» и выбрать пункт «Диаграмма».

Для файла А получим:


Как видно из диаграммы, все точки разбиваются на два кластера, причем для одного кластера все точки находятся выше оси y, а для второго — ниже.

Для файла В:

Данные разбиты на 3 кластера. В 1 кластере у всех точек x < 10, во втором 10 < x < 20, в третьем x > 20.

Далее в программном коде воспользуемся этой информацией, когда будем группировать точки по кластерам.

На языке программирования Python программа будет выглядеть следующим образом.

import math

def distance(p1, p2):
    return math.sqrt((p2[0] - p1[0])**2 + (p2[1] - p1[1])**2)

def sum_distances(point, points):
    return sum(distance(point, p) for p in points)

def find_center(points):
    # Проверяем все возможные комбинации точек как потенциальных центров
    min_sum = float('inf')
    center = None
    for p in points:
        current_sum = sum_distances(p, points)
        if current_sum < min_sum:
            min_sum = current_sum
            center = p
    return center

def process_file_a(filename, cluster_count):
    # Читаем координаты точек
    with open(filename, 'r') as file:
        file = [i.replace(',','.') for i in file.read().splitlines()[1:]]
        points = [tuple(map(float, line.split())) for line in file]
    
    # Разбиваем точки на кластеры
    clusters = [[] for _ in range(cluster_count)]
    for point in points:
        if point[1] > 0:
            clusters[0].append(point)
        else:
            clusters[1].append(point)

    
    # Находим центры кластеров
    centers = [find_center(cluster) for cluster in clusters]
    
    # Вычисляем средние координаты центров
    Px = sum(c[0] for c in centers) / cluster_count
    Py = sum(c[1] for c in centers) / cluster_count
    
    return Px, Py

def process_file_b(filename, cluster_count):
    # Читаем координаты точек
    with open(filename, 'r') as file:
        file = [i.replace(',','.') for i in file.read().splitlines()[1:]]
        points = [tuple(map(float, line.split())) for line in file]
    
    # Разбиваем точки на кластеры
    clusters = [[] for _ in range(cluster_count)]
    for point in points:
        if point[0] < 10:
            clusters[0].append(point)
        elif point[0] < 20:
            clusters[1].append(point)
        else:
            clusters[2].append(point)
    
    # Находим центры кластеров
    centers = [find_center(cluster) for cluster in clusters]
    
    # Вычисляем средние координаты центров
    Px = sum(c[0] for c in centers) / cluster_count
    Py = sum(c[1] for c in centers) / cluster_count
    
    return Px, Py

## Обрабатываем файл A
Px_A, Py_A = process_file_a('1_27_A.txt', 2)
print(f"Файл A: Px = {int(Px_A * 10000)}, Py = {int(Py_A * 10000)}")

## Обрабатываем файл Б
Px_B, Py_B = process_file_b('1_27_B.txt', 3)
print(f"Файл Б: Px = {int(Px_B * 10000)}, Py = {int(Py_B * 10000)}")

Таким образом, дял файла А: 26216 — абсолютное значение целой части произведения Px × 10 000, 24182 — абсолютное значение целой части произведения Py × 10 000. Для файла Б: 150 891 — абсолютное значение целой части произведения Px × 10 000, 63 754 — абсолютное значение целой части произведения Py × 10 000.

Показать ответ

Источник: Открытый вариант — 2025
Сообщить об ошибке


Тест с похожими заданиями