Задание №6511. Все пятибуквенные слова, составленные из букв С, Т, Р, О, К, А, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. ААААА 2. ААААК 3. ААААО 4. ААААР 5. ААААС 6. ААААТ …… Определите, под каким номером в этом списке стоит последнее слово с чётным номером, которое не начинается с букв А, С или Т и при этом содержит в своей записи ровно две буквы О. Примечание. Слово – последовательность идущих подряд букв, не обязательно осмысленная.

Задание №6511.
Измерение количества информации. ЕГЭ по информатике

Все пятибуквенные слова, составленные из букв С, Т, Р, О, К, А, записаны в алфавитном порядке и пронумерованы.

Вот начало списка:
1. ААААА
2. ААААК
3. ААААО
4. ААААР
5. ААААС
6. ААААТ
……

Определите, под каким номером в этом списке стоит последнее слово с чётным номером, которое не начинается с букв А, С или Т и при этом содержит в своей записи ровно две буквы О.

Примечание. Слово – последовательность идущих подряд букв, не обязательно осмысленная.

Пояснение:
Решим задание, написав программу на языке программирования Python.

from itertools import product

letters = ['А', 'К', 'О', 'Р', 'С', 'Т'] # алфавитный порядок

# Генерируем все слова
words = []
for word_chars in product(letters, repeat=5):
    words.append(''.join(word_chars))

even_valid_words = []
for idx, word in enumerate(words, start=1):
    if idx % 2 != 0:
        continue
    if word[0] in ['А', 'С', 'Т']:
        continue
    if word.count('О') == 2:
        even_valid_words.append((idx, word))

if even_valid_words:
    last_even_valid = even_valid_words[-1]
    print(f"Последнее подходящее слово: {last_even_valid[1]}")
    print(f"Его номер: {last_even_valid[0]}")
else:
    print("Нет подходящих слов")

Таким образом, под номером 5058 в этом списке стоит последнее слово с чётным номером, которое не начинается с букв А, С или Т и при этом содержит в своей записи ровно две буквы О.

Показать ответ

Источник: Демонстрационный вариант ЕГЭ — 2026
Сообщить об ошибке


Тест с похожими заданиями