Задание №6512. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите сумму чисел в строке с наибольшим номером, для которой выполнены оба условия: – в строке есть одно число, которое повторяется трижды, остальные четыре числа различны; – среднее арифметическое неповторяющихся чисел строки не больше повторяющегося числа. В ответе запишите только число.

Задание №6512.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите сумму чисел в строке с наибольшим номером, для которой выполнены оба условия:

– в строке есть одно число, которое повторяется трижды, остальные четыре числа различны;

– среднее арифметическое неповторяющихся чисел строки не больше повторяющегося числа.

В ответе запишите только число.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое .ods файла в текстовый документ с расширением .txt.

with open('input.txt') as file:
    numbers = file.read().splitlines()

max_line_number = -1
max_line_sum = 0

for line_num, line in enumerate(numbers, 1):
    # Преобразуем строку в список чисел и сортируем
    nums = sorted([int(i) for i in line.split('\t')])
    
    # Проверяем первое условие: одно число повторяется трижды, остальные четыре различны
    from collections import Counter
    count = Counter(nums)
    
    # Должно быть ровно одно число с частотой 3, и остальные числа должны быть уникальными
    triple_numbers = [num for num, freq in count.items() if freq == 3]
    if len(triple_numbers) != 1:
        continue
    
    # Проверяем, что всего 5 уникальных чисел (одно повторяется трижды, остальные четыре различны)
    if len(count) != 5:
        continue
    
    triple_num = triple_numbers[0]
    
    # Второе условие: среднее арифметическое неповторяющихся чисел не больше повторяющегося числа
    unique_numbers = [num for num, freq in count.items() if freq == 1]
    avg_unique = sum(unique_numbers) / len(unique_numbers) if unique_numbers else 0
    
    if avg_unique <= triple_num:
        # Если оба условия выполнены и это строка с наибольшим номером
        if line_num > max_line_number:
            max_line_number = line_num
            max_line_sum = sum(nums)

print(max_line_sum)

Таким образом, 901 — сумму чисел в строке с наибольшим номером, для которой выполнены оба условия.

Показать ответ

Источник: Демонстрационный вариант ЕГЭ — 2026
Сообщить об ошибке


Тест с похожими заданиями