Задание №6517. Значение арифметического выражения 2 ∙ 21872020 + 7292021 – 2 ∙ 2432022 + 812023 – 2 ∙ 272024 – 6561. записали в системе счисления с основанием 27. Определите в 27-ричной записи числа количество цифр с числовым значением, превышающим 9.

Задание №6517.
Позиционные системы счисления. ЕГЭ по информатике

Значение арифметического выражения

2 ∙ 21872020 + 7292021 – 2 ∙ 2432022 + 812023 – 2 ∙ 272024 – 6561.

записали в системе счисления с основанием 27. Определите в 27-ричной записи числа количество цифр с числовым значением, превышающим 9.

Пояснение:
Решим задание, написав программу на языке программирования Python.

numbers_0_9 = [0, 1, 2, 3, 4, 5, 6, 7, 8, 9]

n = 2 * 2187 ** 2020 + 729 ** 2021 - 2 * 243 ** 2022 + 81 ** 2023 - 2 * 27 ** 2024 - 6561
count = 0
while n:
    if n % 27 not in numbers_0_9:
        count += 1
    n //= 27
print(count)

Таким образом, в 27-ричной записи числа 3367 цифр с числовым значением, превышающим 9.

Показать ответ

Источник: Демонстрационный вариант ЕГЭ — 2026
Сообщить об ошибке


Тест с похожими заданиями