Задание №6520. Файл, необходимый для выполнения задания: ссылка для скачивания. В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых только один из элементов является двузначным числом, а сумма элементов пары кратна минимальному двузначному элементу последовательности. В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Задание №6520.
Составление алгоритма обработки числовой последовательности. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых только один из элементов является двузначным числом, а сумма элементов пары кратна минимальному двузначному элементу последовательности. В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Пояснение:
Решим задание, написав программу на языке программирования Python.

with open('input.txt', encoding='utf8') as f: # читаем файл
    # получаем список чисел
    numbers = [int(i) for i in f.read().splitlines()]

# находим минимальное двузначное
min_two_digit = min(x for x in numbers if 10 <= x <= 99)

count = 0
max_sum = 0

for i in range(len(numbers) - 1):
    a, b = numbers[i], numbers[i + 1]

    # проверяем: только один из элементов двузначный
    cond_one_two_digit = (10 <= a <= 99) ^ (10 <= b <= 99)

    if cond_one_two_digit:
        s = a + b
        if s % min_two_digit == 0:
            count += 1
            if s > max_sum:
                max_sum = s

print(count, max_sum)

Таким образом, 150 — количество найденных пар чисел, а 9930 — максимальная из сумм элементов таких пар.

Показать ответ

Источник: Демонстрационный вариант ЕГЭ — 2026
Сообщить об ошибке


Тест с похожими заданиями