Задание №6524. Для игры, описанной в задании 19, найдите минимальное значение S, при котором одновременно выполняются два условия: – у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети; – у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Задание №6524.
Построение дерева игры по заданному алгоритму. ЕГЭ по информатике

Для игры, описанной в задании 19, найдите минимальное значение S, при котором одновременно выполняются два условия:

– у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

– у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def moves(x): return [x-3, x-5, x//4]
def win(x): return x <= 30

for S in range(31, 2000):
    pm = moves(S)
    # Петя не должен выигрывать сразу
    if any(win(p) for p in pm):
        continue
    # У Вани не должно быть гарантированного выигрыша первым ходом
    if all(any(win(v) for v in moves(p)) for p in pm):
        continue
    # Проверяем: при любом ходе Пети Ваня выигрывает 1-м или 2-м своим ходом
    ok = True
    for p in pm:
        good = False
        for v in moves(p):
            if win(v) or all(not win(r) and any(win(v2) for v2 in moves(r)) for r in moves(v)):
                good = True; break
        if not good:
            ok = False; break
    if ok:
        print(S)
        break

Таким образом, 132 — минимальное значение S, при котором одновременно выполняются два условия.

Показать ответ

Источник: Демонстрационный вариант ЕГЭ — 2026
Сообщить об ошибке


Тест с похожими заданиями