Тест 6. Задания с кратким ответом. ОГЭ по информатике

Тест 6. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова написал текст (в нём нет лишних пробелов):

«Школьные предметы: ОБЖ, химия, физика, алгебра, биология, география, литература, информатика».

Ученик удалил из списка название одного предмета, а также лишние запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 16 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название предмета.



2) От разведчика было получено сообщение:

1110001100010110

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, З, И, К, О, Ф; каждая буква кодировалась двоичным словом по такой таблице:

АЗИКОФ
1100110001000011

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите наименьшее натуральное число x, для которого истинно высказывание:

(x < 4) И (x > 1) И (x ≠ 2).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых приведена в таблице.

 ABCDE
A 5969
B5 3
C9 22
D632 5
E925 

Определите длину кратчайшего пути между пунктами A и E, проходящего через пункт D. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 3

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 3, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 12121 переводит число 3 в число 168.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > 10 или t > А
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > 10) or (t > А)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > 10 OR t > А THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > 10) or (t > А):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > 10 || t > А)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(1, 2); (11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).

Укажите наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» три раза.



7) Доступ к файлу ru.txt, находящемуся на сервере htm.com, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) /
2) http
3) .com
4) ://
5) ru
6) .txt
7) htm



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Волга & (Ока | Кама)505
Волга & Ока230
Волга & Кама400

Какое количество страниц (в тысячах) будет найдено по запросу Волга & Ока & Кама?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

1516, 248, 101102




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Ф.М. Достоевского, текст которого приведён в подкаталоге каталога Проза, присутствует эпизод, в котором рассказывается о домах генерала Епанчина. С помощью поисковых средств операционной системы и текстового редактора выясните, на какой улице находился его второй дом. В ответе запишите название улицы в именительном падеже.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов объёмом менее 4 Мб каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.