Тест 9. Задания с кратким ответом. ОГЭ по информатике


Тест 9. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке КОИ-8 каждый символ кодируется 8 битами.

Вова написал текст (в нём нет лишних пробелов):

«Бор, азот, гелий, натрий, водород, кислород, рентгений, менделевий, резерфордий – химические элементы».

Ученик вычеркнул из списка название одного химического элемента. Заодно он вычеркнул ставшие лишними запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 6 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название элемента.



2) От разведчика было получено сообщение:

001001110010110

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, В, Н, О, Р, Т; каждая буква кодировалась двоичным словом по такой таблице:

АВНОРТ
1100001010011111

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите наименьшее двузначное число, большее 54, для которого ложно высказывание:

(Число < 40) ИЛИ НЕ (Число чётное).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDEF
A 315
B3 237
C2 13
D31 1
E731 2
F15 2

Определите длину кратчайшего пути между пунктами A и F, проходящего через пункт C. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 2

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 2, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 11121 переводит число 7 в число 119.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > А или t > 11
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > А) or (t > 11)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > А OR t > 11 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > А) or (t > 11):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > А || t > 11)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).

Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» три раза.



7) Доступ к файлу net.html, находящемуся на сервере txt.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) .html
2) /
3) .ru
4) net
5) ://
6) http
7) txt



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в сотнях тысяч)
Куприн65
Яма119
Овраг112
Куприн | Яма | Овраг235
Куприн & Яма16
Куприн & Овраг0

Какое количество страниц (в сотнях тысяч) будет найдено по запросу Яма & Овраг?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город Е?





10) Среди приведённых ниже трёх чисел, записанных в десятичной системе счисления, найдите число, в двоичной записи которого наименьшее количество единиц. В ответе запишите количество единиц в двоичной записи этого числа.

1610, 2210, 2910




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений М.Ю. Лермонтова, текст которого приведён в подкаталоге каталога Проза, описывается город, в котором герой чуть не умер с голода, да ещё его там хотели утопить. С помощью поисковых средств операционной системы и текстового редактора выясните название этого города.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов объёмом более 3 Мб каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.