Тест 14. Задания с кратким ответом. ОГЭ по информатике

Тест 14. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке КОИ-8 каждый символ кодируется 8 битами. Вова написал текст (в нём нет лишних пробелов):

«Алый, синий, фуксия, красный, янтарный, оранжевый, фиолетовый, канареечный, баклажановый – цвета».

Ученик вычеркнул из списка название одного цвета. Заодно он вычеркнул ставшие лишними запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 14 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название цвета.



2) От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе.

● – ● – – ● – – ● ● – ● ● – – ●

При передаче радиограммы было потеряно разбиение на буквы, но известно, что использовались только следующие буквы.

АГИПМ
● –– – ●● ●● – – ●– –

Определите текст радиограммы. В ответе укажите буквы, которые встречаются в тексте радиограммы более одного раза.



3) Напишите наименьшее натуральное число x, для которого истинно высказывание:

НЕ (x < 6) И (x < 7).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDE
A 124
B1 4
C24 1
D 4
E414 

Определите длину кратчайшего пути между пунктами B и D. Передвигаться можно только по дорогам, протяжённость которых указана в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 6

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 6, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 3 по алгоритму 12121 будет получено число 54.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > A или t > 12
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > A) or (t > 12)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > A OR t > 12 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > A) or (t > 12):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > A || t > 12)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).

Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» четыре раза.



7) Доступ к файлу hi.txt, находящемуся на сервере txt.ru, осуществляется по протоколу https. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) ://
2) txt.
3) .txt
4) https
5) hi
6) /
7) ru



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Евклид & Аристотель240
Евклид & (Аристотель | Платон)450
Евклид & Аристотель & Платон90

Компьютер печатает количество страниц (в тысячах), которое будет найдено по следующему запросу: Евклид & Платон.

Укажите целое число, которое напечатает компьютер.

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке – схема дорог, связывающих населённые пункты A, B, C, D, E, F, G. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из населённого пункта А в населённый пункт G?





10) Среди приведённых ниже трёх чисел, записанных в десятичной системе счисления, найдите число, в двоичной записи которого наименьшее количество единиц. В ответе запишите количество единиц в двоичной записи этого числа.

6710, 7910, 9410




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, у одного из персонажей есть семилетний сын по имени Фемистоклюс. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните, как зовут младшего брата этого мальчика.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением htm, каждый объёмом от 100 Кб до 148 Кб включительно, содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.