Тест 15. Задания с кратким ответом. ОГЭ по информатике


Тест 15. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке Windows-1251 каждый символ кодируется 8 битами. Вова хотел написать текст (в нём нет лишних пробелов):

«Скользя по утреннему снегу,

Друг милый, предадимся бегу

Нетерпеливого коня

И навестим поля пустые…»

Одно из слов ученик написал два раза подряд, поставив между одинаковыми словами один пробел. При этом размер написанного предложения в данной кодировке оказался на 10 байт больше, чем размер нужного предложения. Напишите в ответе лишнее слово.



2) От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе.

– – – – ● ● – ● ● – – ● ● ●

При передаче радиограммы было потеряно разбиение на буквы, но известно, что использовались только следующие буквы.

ЕНОЗЩ
– ●– – –– – ● ●– – ● –

Определите текст радиограммы. В ответе укажите буквы, которые встречаются в тексте радиограммы более одного раза.



3) Напишите наименьшее натуральное число x, для которого истинно высказывание:

(x < 3) И ((x < 2) ИЛИ (x > 2)).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDEF
A 3415
B3 2
C42 1
D1 26
E2 2
F156 2

Определите длину кратчайшего пути между пунктами A и F, не проходящего через пункт B. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 4

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 4, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 2 по алгоритму 11212 будет получено число 102.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > A или t > 12
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > A) or (t > 12)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > A OR t > 12 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > A) or (t > 12):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > A || t > 12)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).

Укажите наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» шесть раз.



7) Доступ к файлу ftp.jpg, находящемуся на сервере text.net, осуществляется по протоколу ftp. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) .net
2) jpg
3) ftp.
4) //
5) ftp:
6) /
7) text



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Хоккей & Россия168
Хоккей & Канада237
Хоккей & Россия & Канада79

Какое количество страниц (в тысячах) будет найдено по запросу Хоккей & (Россия | Канада)?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих искомые слова, не изменялся за время выполнения запросов.



9) На рисунке – схема дорог, связывающих города A, B, C, D, E, F. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город F?





10) Среди приведённых ниже трёх чисел, записанных в десятичной системе счисления, найдите число, в двоичной записи которого наименьшее количество единиц. В ответе запишите количество единиц в двоичной записи этого числа.

1310, 1510, 1710




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений А.С. Пушкина, текст которого приведён в подкаталоге каталога Проза, упоминается собака по кличке Сбогар. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните имя хозяина собаки.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением htm объёмом более 51200 байт каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.