Тест 20. Задания с кратким ответом. ОГЭ по информатике


Тест 20. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова написал текст (в нём нет лишних пробелов):

«Школьные предметы: ОБЖ, химия, физика, алгебра, биология, география, литература, информатика».

Ученик удалил из списка название одного предмета, а также лишние запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 14 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название предмета.



2) Мальчики играли в шпионов и закодировали сообщение придуманным шифром. В сообщении присутствуют только буквы из приведённого фрагмента кодовой таблицы.

СТУФХЦЧ
+ + *+ −+ * +* *− *+ * *

Расшифруйте сообщение. Получившееся слово (набор букв) запишите в качестве ответа.

− * * * + + * + + * + −




3) Напишите наименьшее натуральное число x, для которого ложно высказывание:

(x > 2) ИЛИ НЕ (x > 1).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDEF
A 1515
B1 2
C52 1
D1 26
E2 1
F156 1

Определите длину кратчайшего пути между пунктами A и F, проходящего через пункт E. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 2

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 2, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 7 по алгоритму 12111 будет получено число 51.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > A или t > 12
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > A) or (t > 12)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > A OR t > 12 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > A) or (t > 12):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > A || t > 12)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).

Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» пять раз.



7) Доступ к файлу hi.gif, находящемуся на сервере past.ru, осуществляется по протоколу https. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) ru
2) ://
3) past.
4) .gif
5) https
6) hi
7) /



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в сотнях тысяч)
Кокон22
Гусеница20
Капот40
Капот | Кокон | Гусеница66
Капот & Гусеница10
Капот & Кокон0

Какое количество страниц (в сотнях тысяч) будет найдено по запросу Кокон & Гусеница?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке – схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город З?





10) Переведите число 68 из десятичной системы счисления в двоичную систему счисления. Сколько единиц содержит полученное число? В ответе укажите одно число – количество единиц.



11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, описывается сцена, в которой персонаж с отчеством Петрович осматривает вицмундир. С помощью поисковых средств операционной системы и текстового редактора определите профессию этого человека.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов с расширением .rtf содержится в подкаталогах каталога Поэзия? В ответе укажите только число.