Тест 21. Задания с кратким ответом. ОГЭ по информатике


Тест 21. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова хотел написать текст (в нём нет лишних пробелов):

«Ом, Бор, Кюри, Попов, Джоуль, Рентген, Курчатов, Резерфорд – великие физики».

Фамилию одного учёного ученик написал два раза подряд, добавив необходимые запятую и пробел. При этом размер написанного предложения в данной кодировке оказался на 8 байт больше, чем размер нужного предложения. Напишите в ответе слово, использованное дважды.



2) Мальчики играли в шпионов и закодировали сообщение придуманным шифром. Кодовая таблица приведена ниже.

AБВГЕИК
*– + +– – +* +– *+ – +* * –

Расшифруйте сообщение. В ответе запишите получившееся слово (набор букв).

* + – + + – * * – * *




3) Напишите наименьшее натуральное число x, для которого истинно высказывание:

(x < 3) И НЕ (x < 2).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDE
A 74
B7 24
C42 4
D4 4
E44 

Определите длину кратчайшего пути между пунктами A и E, проходящего через пункт C. Передвигаться можно только по дорогам, протяжённость которых указана в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 8

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 8, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 4 по алгоритму 12211 будет получено число 1744.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > А или t > 11
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > А) or (t > 11)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > А OR t > 11 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > А) or (t > 11):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > А || t > 11)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).

Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» пять раз.



7) Доступ к файлу ftp.xls, находящемуся на сервере mail.info, осуществляется по протоколу ftp. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) xls
2) /
3) ftp.
4) ftp:
5) .info
6) //
7) mail



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Математика & Информатика330
Математика & Физика270
Математика & (Информатика | Физика)520

Какое количество страниц (в тысячах) будет найдено по запросу Математика & Информатика & Физика?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке – схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город З?





10) Переведите число 1101011 из двоичной системы счисления в десятичную систему счисления. В ответе напишите полученное число.



11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, герой рассказывает о том, что он является автором ряда известных литературных произведений, среди которых «Женитьба Фигаро», «Роберт-дьявол», «Норма». Герой утверждает, что подписывал эти произведения псевдонимом. С помощью поисковых средств операционной системы и текстового редактора выясните этот псевдоним.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов объёмом более 15 Кб каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.