Тест 5. Задания с кратким ответом. ОГЭ по информатике


Тест 5. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке Windows-1251 каждый символ кодируется 8 битами. Вова написал текст (в нём нет лишних пробелов):

«Вздыхать и думать про себя: Когда же чёрт возьмёт тебя!»

Ученик вычеркнул из текста одно слово. Заодно он вычеркнул ставший лишним пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 4 байта меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое слово.



2) От разведчика было получено сообщение:

100001100001110

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, П, О, Р, С, Т; каждая буква кодировалась двоичным словом по такой таблице:

АПОРСТ
1011001000100011

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите наименьшее натуральное число x, для которого ложно высказывание:

НЕ (x > 2) ИЛИ (x = 4).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDEF
A 1215
B1 34
C23 16
D41 26
E2 1
F1566 1

Определите длину кратчайшего пути между пунктами A и F, проходящего через пункт С. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 1

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 1, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 12121 переводит число 4 в число 49.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t
  ввод s
  ввод t
  если s > 5 или не t < 3
    то вывод "YES"
    иначе вывод "NO"
  все
кон
var s, t: integer;
begin
 readln(s);
 readln(t);
 if (s > 5) or not (t < 3)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t AS INTEGER
INPUT s
INPUT t
IF s > 5 OR NOT t < 3 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
if (s > 5) or not (t < 3):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t;
   cin >> s;
   cin >> t;
   if ((s > 5) || !(t < 3))
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(2, –2); (–2, 4); (4, 1); (–12, 5); (0, –7); (1, 3); (8, 2); (3, 0); (23, 1).

Сколько было запусков, при которых программа напечатала «NO»?



7) Доступ к файлу org.txt, находящемуся на сервере net.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) org
2) .ru
3) /
4) ://
5) http
6) net
7) .txt



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Новый год & Дед Мороз310
Новый год & Дед Мороз & Санта Клаус55
Новый год & (Дед Мороз | Санта Клаус)489

Какое количество страниц (в тысячах) будет найдено по запросу Новый год & Санта Клаус?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих искомые слова, не изменялся за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город Е?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

4E16, 1178, 1010102




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, есть персонаж Слесарша. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните имя этой героини.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением rtf объёмом более 100 Кб каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.