Тест 1. Задания с кратким ответом. ОГЭ по информатике

Тест 1. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова написал текст (в нём нет лишних пробелов):

«Бор, азот, гелий, натрий, водород, кислород, рентгений, менделевий, резерфордий – химические элементы».

Ученик вычеркнул из списка название одного химического элемента. Заодно он вычеркнул ставшие лишними запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 18 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название элемента.



2) От разведчика было получено сообщение:

0011000001110010

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, Г, Л, М, Н, О; каждая буква кодировалась двоичным словом по такой таблице:

АГЛМНО
1101101000100010

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите наибольшее натуральное число x, для которого ложно высказывание:

НЕ (x < 6) ИЛИ (x < 5).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDEF
A 3515
B3 14
C51 29
D42 36
E3 4
F1596 4

Определите длину кратчайшего пути между пунктами A и F, проходящего через пункт С. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 1

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 1, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 11211 переводит число 8 в число 62.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t
  ввод s
  ввод t
  если s < 4 и не t < 2
    то вывод "YES"
    иначе вывод "NO"
  все
кон
var s, t: integer;
begin
 readln(s);
 readln(t);
 if (s < 4) and not (t < 2)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t AS INTEGER
INPUT s
INPUT t
IF s < 4 AND NOT t < 2 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
if (s < 4) and not (t < 2):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t;
   cin >> s;
   cin >> t;
   if ((s < 4) && !(t < 2))
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(0, 2); (–1, 0); (2, 3); (4, 2); (3, 1); (–2, 7); (10, –2); (5, 4); (–7, 11).

Сколько было запусков, при которых программа напечатала «YES»?



7) Доступ к файлу klara.htm, находящемуся на сервере march.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) klara
2) /
3) march
4) .htm
5) .ru
6) ://
7) http



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Москва & Метро980
Метро4320
Москва5430

Какое количество страниц (в тысячах) будет найдено по запросу Москва | Метро?

Считается, что все запросы выполнялись практически одновременно, так что хранящаяся на поисковом сервере информация о наборе страниц, содержащих все искомые слова, не изменялась за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город В?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

3E16, 448, 10111102




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений А.С. Пушкина, текст которого приведён в подкаталоге каталога Проза, есть героиня Палашка. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните название профессии этой женщины.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов с расширением .htm содержится в подкаталогах каталога Поэзия? В ответе укажите только число.