Тест 3. Задания с кратким ответом. ОГЭ по информатике

Тест 3. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова хотел написать текст (в нём нет лишних пробелов):

«Ом, Бор, Кюри, Попов, Джоуль, Рентген, Курчатов, Резерфорд – великие физики».

Фамилию одного учёного ученик написал два раза подряд, добавив необходимые запятую и пробел. При этом размер написанного предложения в данной кодировке оказался на 20 байт больше, чем размер нужного предложения. Напишите в ответе слово, использованное дважды.



2) От разведчика было получено сообщение:

100100011010001

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, Е, И, К, Л, О; каждая буква кодировалась двоичным словом по такой таблице:

АЕИКЛО
1100111100010001

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите наименьшее натуральное число x, для которого истинно высказывание:

НЕ ((x > 3) ИЛИ (x < 2)) И (x > 2).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых приведена в таблице.

 ABCDE
A 3989
B3 4
C9 22
D842 5
E925 

Определите длину кратчайшего пути между пунктами A и E, проходящего через пункт D. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 1

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 1, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 12211 переводит число 1 в число 100.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t
ввод s
ввод t
если не s > -4 или t < 3
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t: integer;
begin
 readln(s);
 readln(t);
 if not(s > -4) or (t < 3)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t AS INTEGER
INPUT s
INPUT t
IF NOT s > -4 OR t < 3 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
if not (s > -4) or (t < 3):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t;
   cin >> s;
   cin >> t;
   if (!(s > -4) || (t < 3))
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(2, –2); (5, 3); (14, 1); (–12, 5), (5, 7); (10, 3); (8, 2); (3, 0); (–4, 9).

Сколько было запусков, при которых программа напечатала «YES»?



7) Доступ к файлу txt.com, находящемуся на сервере net.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) /
2) net
3) .com
4) ://
5) .ru
6) http
7) txt



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Мопс | Бульдог5500
Мопс2500
Мопс &Бульдог1000

Какое количество страниц (в тысячах) будет найдено по запросу Бульдог?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город Ж?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

2A16, 308, 1101012




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений А.С. Пушкина, текст которого приведён в подкаталоге каталога Проза, одна из героинь эпизода произносит фразу: «Подлинно, нынешние наряды на смех всему миру». С помощью поисковых средств операционной системы и текстового редактора определите имя этой героини. В ответе запишите только её полное имя (без отчества).



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов с расширением .pdf содержится в подкаталогах каталога Поэзия? В ответе укажите только число.