Тест 7. Задания с кратким ответом. ОГЭ по информатике

Тест 7. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова хотел написать текст (в нём нет лишних пробелов):

«Скользя по утреннему снегу,

Друг милый, предадимся бегу

Нетерпеливого коня

И навестим поля пустые…»

Одно из слов ученик написал два раза подряд, поставив между одинаковыми словами один пробел. При этом размер написанного предложения в данной кодировке оказался на 18 байт больше, чем размер нужного предложения. Напишите в ответе лишнее слово.



2) От разведчика было получено сообщение:

111001100101001

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, Г, И, О, Р, Т; каждая буква кодировалась двоичным словом по такой таблице:

АГИОРТ
0111100000010110

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите количество натуральных чисел, для которых истинно высказывание:

НЕ (Число нечётное) И НЕ (Число > 12).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых приведена в таблице.

 ABCDE
A 3989
B3 4
C9 32
D843 2
E922 

Определите длину кратчайшего пути между пунктами A и E, проходящего через пункт D. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 2

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 2, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 11212 переводит число 3 в число 120.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > А или t > 11
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > А) or (t > 11)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > А OR t > 11 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > А) or (t > 11):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > А || t > 11)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).

Укажите наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» три раза.



7) Доступ к файлу com.htm, находящемуся на сервере txt.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) txt
2) http
3) /
4) сom
5) .ru
6) ://
7) .htm



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Новый год & Дед Мороз177
Новый год & Санта Клаус218
Новый год & Дед Мороз & Санта Клаус64

Какое количество страниц (в тысячах) будет найдено по запросу Новый год & (Дед Мороз | Санта Клаус)?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих искомые слова, не изменялся за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город Ж?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

7816, 1208, 100111012




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений А.П. Чехова, текст которого приведён в подкаталоге каталога Проза, есть герой с фамилией Жратва. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните должность этого героя.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением txt объёмом более 10240 байт каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.