Тест 11. Задания с кратким ответом. ОГЭ по информатике

Тест 11. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке КОИ-8 каждый символ кодируется 8 битами. Вова хотел написать текст (в нём нет лишних пробелов):

«Скользя по утреннему снегу,

Друг милый, предадимся бегу

Нетерпеливого коня

И навестим поля пустые…»

Одно из слов ученик написал два раза подряд, поставив между одинаковыми словами один пробел. При этом размер написанного предложения в данной кодировке оказался на 14 байт больше, чем размер нужного предложения. Напишите в ответе лишнее слово.



2) Ваня шифрует русские слова, записывая вместо каждой буквы её номер в алфавите (без пробелов). Номера букв даны в таблице.

А

1

Й

11

У

21

Э

31

Б

2

К

12

Ф

22

Ю

32

В

3

Л

13

Х

23

Я

33

Г

4

М

14

Ц

24

 

 

Д

5

Н

15

Ч

25

 

 

Е

6

О

16

Ш

26

 

 

Ё

7

П

17

Щ

27

 

 

Ж

8

Р

18

Ъ

28

 

 

З

9

С

19

Ы

29

 

 

И

10

Т

20

Ь

30

 

 

Некоторые шифровки можно расшифровать несколькими способами. Например, 311333 может означать «ВАЛЯ», может – «ЭЛЯ», а может – «ВААВВВ».

Даны четыре шифровки:

1510261

8102030

1416184

1816830

Только одна из них расшифровывается единственным способом. Найдите её и расшифруйте. Получившееся слово запишите в качестве ответа.



3) Напишите наибольшее двузначное число, меньшее 75, для которого истинно высказывание:

(Сумма цифр нечетная) И НЕ (Число чётное).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDEF
A 3515
B3 4
C5 1
D41 26
E2 1
F156 1

Определите длину кратчайшего пути между пунктами A и F. Передвигаться можно только по дорогам, указанным в таблице.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 3

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 3, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 5 по алгоритму 11211 будет получено число 116.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > A или t > 12
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > A) or (t > 12)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > A OR t > 12 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > A) or (t > 12):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > A || t > 12)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).

Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» четыре раза.



7) Доступ к файлу tests.rar, находящемуся на сервере olympiada.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) tests
2) http
3) /
4) .ru
5) olympiada
6) ://
7) .rar



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в сотнях тысяч)
Маяковский115
Клоп161
Блоха132
Маяковский | Клоп | Блоха333
Маяковский & Клоп20
Маяковский & Блоха0

Какое количество страниц (в сотнях тысяч) будет найдено по запросу Блоха & Клоп?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке изображена схема соединений, связывающих пункты A, B, C, D, E, F, G, H. По каждому соединению можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из пункта А в пункт H?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

7A16, 1728, 100101012




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений А.С. Пушкина, текст которого приведён в подкаталоге каталога Проза, одному из персонажей говорят: «Государь мой, ты провинился: во-первых, подошед к сей молодой персоне, не отдав ей три должные реверанса; а во-вторых, взяв на себя самому её выбрать, тогда как в этом танце право сие подобает даме, а не кавалеру». С помощью поисковых средств операционной системы и текстового редактора или браузера выясните, как называется этот танец.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением pdf объёмом не менее 1 Мб каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.