Тест 16. Задания с кратким ответом. ОГЭ по информатике

Тест 16. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова написал текст (в нём нет лишних пробелов):

«Школьные предметы: ОБЖ, химия, физика, алгебра, биология, география, литература, информатика».

Ученик удалил из списка название одного предмета, а также лишние запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 18 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название предмета.



2) От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе.

– ● – – ● – – – ● ● ● ● – ●

При передаче радиограммы было потеряно разбиение на буквы, но известно, что использовались только следующие буквы.

ЕНОЗЩ
– ●– – –– – ● ●– – ● –

Определите текст радиограммы. В ответе укажите буквы, которые встречаются в тексте радиограммы более одного раза.



3) Напишите наибольшее натуральное число x, для которого истинно высказывание:

(x < 5) ИЛИ НЕ (x > 3).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDE
A 7262
B7 4
C24 8
D68 3
E23 

Определите длину кратчайшего пути между пунктами B и D. Передвигаться можно только по дорогам, протяжённость которых указана в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 5

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 5, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 3 по алгоритму 21211 будет получено число 52.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > А или t > 11
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > А) or (t > 11)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > А OR t > 11 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > А) or (t > 11):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > А || t > 11)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).

Укажите количество целых значений параметра А, при которых для указанных входных данных программа напечатает «NO» шесть раз.



7) Доступ к файлу http.txt, находящемуся на сервере book.com, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) /
2) http.
3) //
4) http:
5) .com
6) book
7) txt



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в сотнях тысяч)
Напряжённость24
Пшеница38
Напряжённость | Поле | Пшеница98
Поле & Пшеница30
Напряжённость & Поле19
Напряжённость & Пшеница0

Какое количество страниц (в сотнях тысяч) будет найдено по запросу Поле?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке – схема дорог, связывающих города A, B, C, D, E, F, G. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город G?





10) Среди приведённых ниже трёх чисел, записанных в десятичной системе счисления, найдите число, в двоичной записи которого наибольшее количество единиц. В ответе запишите количество единиц в двоичной записи этого числа.

810, 1210, 1610




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, есть персонаж с должностью смотритель училищ. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните фамилию этого героя.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов объёмом более 400000 байт каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.