Тест 19. Задания с кратким ответом. ОГЭ по информатике


Тест 19. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова написал текст (в нём нет лишних пробелов):

«Мой дядя самых честных правил,

Когда не в шутку занемог…»

Ученик вычеркнул из текста одно слово. Заодно он вычеркнул ставший лишним пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 6 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое слово.



2) Мальчики играли в шпионов и закодировали сообщение придуманным шифром. В сообщении присутствуют только буквы из приведённого фрагмента кодовой таблицы.

АБВГДЕЁ
~ο + +ο ο +~ +ο ~+ ο +~ ~ ο

Расшифруйте сообщение. Получившееся слово (набор букв) запишите в качестве ответа.

~ + ο + + ο ~ ~ ο ~ ~




3) Напишите наименьшее натуральное число x, для которого истинно высказывание:

(x > 4) И (x < 7) И (x < 6).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDE
A 124
B 4
C14 4
D24 1
E41 

Определите длину кратчайшего пути между пунктами B и E. Передвигаться можно только по дорогам, протяжённость которых указана в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 3

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 3, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 2 по алгоритму 11211 будет получено число 70.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > A или t > 12
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > A) or (t > 12)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > A OR t > 12 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > A) or (t > 12):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > A || t > 12)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).

Укажите наименьшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» семь раз.



7) Доступ к файлу privet.xls, находящемуся на сервере text.com, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) com
2) .xls
3) text.
4) http
5) privet
6) /
7) ://



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в сотнях тысяч)
Макбет150
Шекспир104
Лесков131
Шекспир | Лесков | Макбет320
Шекспир & Макбет10
Шекспир & Лесков0

Какое количество страниц (в сотнях тысяч) будет найдено по запросу Макбет & Лесков?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке – схема дорог, связывающих города A, B, C, D, E, F, G. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города A в город D?





10) Переведите число 305 из десятичной системы счисления в двоичную систему счисления. Сколько единиц содержит полученное число? В ответе укажите одно число – количество единиц.



11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, автор описывает одним словом «мелкий кривой дрянной лес, кустами поросший от корней». С помощью поисковых средств операционной системы и текстового редактора или браузера выясните это слово.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением rtf объёмом не менее 6144 Кб каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.