Тест 4. Задания с кратким ответом. ОГЭ по информатике

Тест 4. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке КОИ-8 каждый символ кодируется 8 битами. Вова написал текст (в нём нет лишних пробелов):

«Личи, гуава, дуриан, кумкват, тамаринд, мангустин, джаботикаба – экзотические фрукты».

Ученик вычеркнул из списка название одного фрукта. Заодно он вычеркнул ставшие лишними запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 7 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название экзотического фрукта.



2) От разведчика было получено сообщение:

1000010110011101

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, Е, З, И, Р, Т; каждая буква кодировалась двоичным словом по такой таблице:

АЕЗИРТ
0011101011100010

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите наименьшее натуральное число x, для которого ложно высказывание:

(x > 3) ИЛИ НЕ ((x < 4) И (x > 2)).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых приведена в таблице.

 ABCDE
A 5653
B5 4
C6 22
D542 5
E325 

Определите длину кратчайшего пути между пунктами A и D, проходящего через пункт С. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 1

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 1, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 11221 переводит число 3 в число 81.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
  цел  s, k
  ввод s
  ввод k
  если s < 6 и k < 6
    то вывод "YES"
    иначе вывод "NO"
  все
кон
var s, k: integer;
begin
 readln(s);
 readln(k);
 if (s < 6) and (k < 6)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM k, s AS INTEGER
INPUT s
INPUT k
IF s < 6 AND k < 6 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
k = int(input())
if s < 6 and k < 6:
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
 int s, k;
 cin >> s;
 cin >> k;
 if (s < 6 && k < 6)
    cout << "YES" << endl;
 else
    cout << "NO" << endl;
 return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и k вводились следующие пары чисел:

(1, 1); (7, 9); (8, –12); (6, 6); (3, 11); (–10, –12); (–10, 11); (7, 1); (12, 7).

Сколько было запусков, при которых программа напечатала «YES»?



7) Доступ к файлу net.txt, находящемуся на сервере org.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) /
2) http
3) org
4) ://
5) .ru
6) net
7) .txt



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Сосна | Берёза7150
Сосна4000
Берёза3820

Какое количество страниц (в тысячах) будет найдено по запросу Сосна & Берёза?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город Д?





10) Среди приведённых ниже трёх чисел, записанных в различных системах счисления, найдите максимальное и запишите его в ответе в десятичной системе счисления. В ответе запишите только число, основание системы счисления указывать не нужно.

9816, 418, 10110112




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений И.А. Гончарова, текст которого приведён в подкаталоге каталога Проза, присутствует эпизод, в котором описывается внешний вид персонажа по имени Захар. С помощью поисковых средств операционной системы и текстового редактора выясните, какого цвета был любимый сюртук Захара. В ответе укажите только название цвета в именительном падеже.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов с расширением .htm содержится в подкаталогах каталога Проза? В ответе укажите только число.