Тест 17. Задания с кратким ответом. ОГЭ по информатике


Тест 17. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке КОИ-8 каждый символ кодируется 8 битами. Вова написал текст (в нём нет лишних пробелов):

«Школьные предметы: ОБЖ, химия, физика, алгебра, биология, география, литература, информатика».

Ученик удалил из списка название одного предмета, а также лишние запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 11 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название предмета.



2) От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе.

– ● ● ● – ● ● – – ● ● – ● – –

При передаче радиограммы было потеряно разбиение на буквы, но известно, что использовались только следующие буквы.

АДЛТЖ
● –– ● ●● – ● ●● ● ● –

Определите текст радиограммы. В ответе укажите буквы, которые встречаются в тексте радиограммы более одного раза.



3) Напишите наибольшее натуральное число x, для которого ложно высказывание:

НЕ (x < 7) ИЛИ (x < 6).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых приведена в таблице.

 ABCDEF
A 53
B5 62
C3 54
D6 35
E253 
F45 

Определите длину кратчайшего пути между пунктами A и D, проходящего через E (при условии, что передвигаться можно только по указанным в таблице дорогам). Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 7

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 7, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 5 по алгоритму 12121 будет получено число 227.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > 10 или t > А
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > 10) or (t > А)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > 10 OR t > А THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > 10) or (t > А):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main(){
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > 10 || t > А)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(1, 2); (11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).

Укажите целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» четыре раза.



7) Доступ к файлу https.txt, находящемуся на сервере smile.ru, осуществляется по протоколу https. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) https:
2) /
3) smile
4) https.
5) .ru
6) txt
7) //



8) Некоторый сегмент сети Интернет состоит из 1000 сайтов. Поисковый сервер в автоматическом режиме составил таблицу ключевых слов для сайтов этого сегмента. Вот её фрагмент.

Ключевое словоКоличество сайтов, для которых данное слово является ключевым
Сканер200
Принтер250
Монитор450

Сколько сайтов будет найдено по запросу (Принтер | Сканер) & Монитор, если по запросу Принтер | Сканер было найдено 450 сайтов; по запросу Принтер & Монитор – 40, а по запросу Сканер & Монитор – 50?

Для обозначения логической операции «ИЛИ» в запросах используется символ «|», а для обозначения логической операции «И» – символ «&».



9) На рисунке – схема дорог, связывающих города A, B, C, D, E, F, G. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город G?





10) Среди приведённых ниже трёх чисел, записанных в десятичной системе счисления, найдите число, в двоичной записи которого наибольшее количество единиц. В ответе запишите количество единиц в двоичной записи этого числа.

2110, 3210, 4010




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений А.С. Пушкина, текст которого приведён в подкаталоге каталога Проза, есть герой Кузов. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните имя этого героя.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением pdf, каждый объёмом от 2048 Кб до 3072 Кб включительно, содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.