Тест 18. Задания с кратким ответом. ОГЭ по информатике

Тест 18. Задания с кратким ответом. ОГЭ по информатике


1) В кодировке КОИ-8 каждый символ кодируется 8 битами. Вова написал текст (в нём нет лишних пробелов):

«Бор, азот, гелий, натрий, водород, кислород, рентгений, менделевий, резерфордий – химические элементы».

Ученик вычеркнул из списка название одного химического элемента. Заодно он вычеркнул ставшие лишними запятую и пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 12 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название элемента.



2) От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе.

– ● – ● – ● – – ● ● – ● ● – ● – ● ●

При передаче радиограммы было потеряно разбиение на буквы, но известно, что использовались только следующие буквы.

НКИЛМ
– ●– ● –● ●● – ● ●– –

Определите текст радиограммы. В ответе запишите буквы, встречающиеся в сообщении более одного раза.



3) Напишите наибольшее натуральное двузначное число, для которого истинно высказывание:

НЕ (Число нечётное) И (Число кратно 3).




4) Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDE
A 23
B2 135
C31 43
D34 1
E531 

Определите длину кратчайшего пути между пунктами A и E, проходящего через пункт С. Передвигаться можно только по дорогам, протяжённость которых указана в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Альфа две команды, которым присвоены номера:

1. прибавь 8

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Первая из них увеличивает число на экране на 8, вторая умножает его на b. Алгоритм для исполнителя Альфа – это последовательность номеров команд. Найдите значение числа b, при котором из числа 4 по алгоритму 11121 будет получено число 148.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > A или t > 12
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > A) or (t > 12)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > A OR t > 12 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > A) or (t > 12):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > A || t > 12)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).

Укажите количество целых значений параметра А, при которых для указанных входных данных программа напечатает «YES» три раза.



7) Доступ к файлу hello.jpg, находящемуся на сервере home.info, осуществляется по протоколу ftp. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) info
2) ://
3) home.
4) /
5) hello
6) ftp
7) .jpg



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в тысячах)
Грибы & Рыбалка134
Грибы & Охота243
Грибы & Рыбалка & Охота78

Какое количество страниц (в тысячах) будет найдено по запросу Грибы & (Рыбалка | Охота)?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих искомые слова, не изменялся за время выполнения запросов.



9) На рисунке – схема дорог, связывающих города A, B, C, D, E, F, G, H. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город H?





10) Среди приведённых ниже трёх чисел, записанных в десятичной системе счисления, найдите число, в двоичной записи которого наибольшее количество единиц. В ответе запишите количество единиц в двоичной записи этого числа.

2510, 2910, 3710




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, есть описание строения, которое автор называет «Храм уединённого размышления». С помощью поисковых средств операционной системы и текстового редактора или браузера выясните название деревни, в которой расположено это строение.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов c расширением pdf объёмом не более 200 Кб каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.