Тест 8. Задания с кратким ответом. ОГЭ по информатике


Тест 8. Задания с кратким ответом. ОГЭ по информатике


1) В одной из кодировок Unicode каждый символ кодируется 16 битами.

Вова написал текст (в нём нет лишних пробелов):

«Вздыхать и думать про себя:

Когда же чёрт возьмёт тебя!»

Ученик вычеркнул из текста одно слово. Заодно он вычеркнул ставший лишним пробел – два пробела не должны идти подряд.

При этом размер нового предложения в данной кодировке оказался на 6 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое слово.



2) От разведчика было получено сообщение:

11011001101010

В этом сообщении зашифрован пароль — последовательность русских букв.

В пароле использовались только буквы А, В, З, И, К, О; каждая буква кодировалась двоичным словом по такой таблице:

АВЗИКО
0110001000011110

Расшифруйте сообщение. Запишите в ответе пароль.



3) Напишите наибольшее натуральное число x, для которого истинно высказывание:

НЕ (x < 3) И (x < 4).




4) Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.

 ABCDEF
A 3415
B3 34
C43 16
D41 26
E2 1
F1566 1

Определите длину кратчайшего пути между пунктами A и F, проходящего через пункт С. Передвигаться можно только по дорогам, указанным в таблице. Каждый пункт можно посетить только один раз.



5) У исполнителя Алго две команды, которым присвоены номера:

1. прибавь 2

2. умножь на b

(b — неизвестное натуральное число; b ≥ 2).

Выполняя первую из них, Алго увеличивает число на экране на 2, а выполняя вторую, умножает это число на b.

Программа для исполнителя Алго — это последовательность номеров команд.

Известно, что программа 21121 переводит число 3 в число 134.

Определите значение b.



6) Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический языкПаскаль
алг
нач
цел s, t, A
ввод s
ввод t
ввод A
если s > A или t > 12
  то вывод "YES"
  иначе вывод "NO"
все
кон
var s, t, A: integer;
begin
 readln(s);
 readln(t);
 readln(A);
 if (s > A) or (t > 12)
  then
   writeln("YES")
  else
   writeln("NO")
end.
БейсикPython
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > A OR t > 12 THEN
  PRINT "YES"
ELSE
  PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())
if (s > A) or (t > 12):
    print("YES")
else:
    print("NO")
C++
#include <iostream>
using namespace std;
 
int main() {
   int s, t, A;
   cin >> s;
   cin >> t;
   cin >> A;
   if (s > A || t > 12)
     cout << "YES" << endl;
   else
     cout << "NO" << endl;
   return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13).

Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» шесть раз.



7) Доступ к файлу edu.txt, находящемуся на сервере htm.ru, осуществляется по протоколу http. Фрагменты адреса файла закодированы цифрами от 1 до 7. Запишите последовательность этих цифр, кодирующую адрес указанного файла в сети Интернет.

1) htm
2) ://
3) /
4) http
5) .ru
6) .txt
7) edu



8) В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И» – символ «&».

В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

ЗапросНайдено страниц (в сотнях тысяч)
Стихотворение113
Пушкин83
Лесков70
Стихотворение | Пушкин | Лесков211
Стихотворение & Пушкин22
Стихотворение & Лесков0

Какое количество страниц (в сотнях тысяч) будет найдено по запросу Пушкин & Лесков?

Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.



9) На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город К, проходящих через город В?





10) Среди приведённых ниже трёх чисел, записанных в десятичной системе счисления, найдите число, в двоичной записи которого наименьшее количество единиц. В ответе запишите количество единиц в двоичной записи этого числа.

2510, 3410, 4110




11) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

В одном из произведений Н.В. Гоголя, текст которого приведён в подкаталоге каталога Проза, есть герой с фамилией Кукубенко. С помощью поисковых средств операционной системы и текстового редактора или браузера выясните должность этого героя.



12) Задание выполняется на компьютере.

Архив, необходимый для выполнения задания: ссылка для скачивания.

Сколько файлов объёмом более 8 Мб каждый содержится в подкаталогах каталога DEMO-12? В ответе укажите только число.